orbit: New package
An MVC web framework for Lua [Thomas P: add patch to fix installation procedure, and use the provided Makefile for installation. Remove build-time dependency on wsapi since there's nothing to build in 'orbit'. Remove run-time dependency on 'rings', since it's not clear why Orbit would depend on that.] Signed-off-by: Assaf Inbal <shmuelzon@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
f608c7705f
commit
02e4326fe7
@ -341,6 +341,7 @@ source "package/luasocket/Config.in"
|
||||
source "package/luasql/Config.in"
|
||||
source "package/lua-ev/Config.in"
|
||||
source "package/lua-msgpack-native/Config.in"
|
||||
source "package/orbit/Config.in"
|
||||
source "package/rings/Config.in"
|
||||
source "package/wsapi/Config.in"
|
||||
source "package/xavante/Config.in"
|
||||
|
10
package/orbit/Config.in
Normal file
10
package/orbit/Config.in
Normal file
@ -0,0 +1,10 @@
|
||||
config BR2_PACKAGE_ORBIT
|
||||
bool "orbit"
|
||||
# These are runtime dependencies
|
||||
select BR2_PACKAGE_WSAPI
|
||||
select BR2_PACKAGE_LUAFILESYSTEM
|
||||
help
|
||||
An MVC web framework for Lua. The design is inspired by lightweight
|
||||
Ruby frameworks such as Camping
|
||||
|
||||
http://keplerproject.github.com/orbit
|
26
package/orbit/orbit-01-fix-installation.patch
Normal file
26
package/orbit/orbit-01-fix-installation.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Fix installation commands
|
||||
|
||||
The installation commands did not match the location of the source
|
||||
files within the Orbit source tree.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -11,12 +11,9 @@
|
||||
mkdir -p $(LUA_DIR)
|
||||
cp src/orbit.lua $(LUA_DIR)
|
||||
mkdir -p $(LUA_DIR)/orbit
|
||||
- cp src/model.lua $(LUA_DIR)/orbit
|
||||
- cp src/cache.lua $(LUA_DIR)/orbit
|
||||
- cp src/pages.lua $(LUA_DIR)/orbit
|
||||
- cp src/ophandler.lua $(LUA_DIR)/orbit
|
||||
+ cp src/orbit/*.lua $(LUA_DIR)/orbit
|
||||
mkdir -p $(BIN_DIR)
|
||||
- cp src/orbit $(BIN_DIR)
|
||||
+ cp src/launchers/* $(BIN_DIR)
|
||||
if [ -f ./wsapi/Makefile ]; then \
|
||||
cd wsapi && make install; \
|
||||
fi
|
19
package/orbit/orbit.mk
Normal file
19
package/orbit/orbit.mk
Normal file
@ -0,0 +1,19 @@
|
||||
################################################################################
|
||||
#
|
||||
# orbit
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ORBIT_VERSION = 2.2.0
|
||||
ORBIT_SITE = http://github.com/downloads/keplerproject/orbit
|
||||
ORBIT_LICENSE = MIT
|
||||
ORBIT_LICENSE_FILES = COPYRIGHT
|
||||
|
||||
define ORBIT_INSTALL_TARGET_CMDS
|
||||
$(MAKE) -C $(@D) \
|
||||
LUA_DIR=$(TARGET_DIR)/usr/share/lua/ \
|
||||
BIN_DIR=$(TARGET_DIR)/usr/bin \
|
||||
install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user