package/supertuxkart: bump to 0.9.3
Remove upstream patches. See: http://blog.supertuxkart.net/2017/11/supertuxkart-093-released.html Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
91bbfe3483
commit
029bf5ff53
@ -1,34 +0,0 @@
|
||||
From 73bed675202cf1f1c748540a4363d7d99e161dca Mon Sep 17 00:00:00 2001
|
||||
From: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
||||
Date: Thu, 9 Jun 2016 18:58:51 -0300
|
||||
Subject: [PATCH 1/2] irrlicht: Get rid of unprefixed cflags
|
||||
|
||||
Cross-building requires proper include paths. This commit
|
||||
removes the unprefixed -I/usr/X11R6/include in irrlicht cflags.
|
||||
|
||||
Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
||||
---
|
||||
Fix sent upstream as part of pull:
|
||||
https://github.com/supertuxkart/stk-code/pull/2554
|
||||
|
||||
lib/irrlicht/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
|
||||
index 46d54008c291..5f4975e3a6f9 100644
|
||||
--- a/lib/irrlicht/CMakeLists.txt
|
||||
+++ b/lib/irrlicht/CMakeLists.txt
|
||||
@@ -25,8 +25,8 @@ elseif(MINGW)
|
||||
add_definitions(-D_IRR_STATIC_LIB_)
|
||||
add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
|
||||
else()
|
||||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing -I/usr/X11R6/include")
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing -I/usr/X11R6/include")
|
||||
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
|
||||
if(CMAKE_COMPILER_IS_GNUCC)
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
|
||||
endif()
|
||||
--
|
||||
2.9.0
|
||||
|
@ -1,39 +0,0 @@
|
||||
From fe71624eb39e0bc302a7603c79503fb12667dc2b Mon Sep 17 00:00:00 2001
|
||||
From: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
||||
Date: Sun, 3 Jul 2016 15:16:59 -0300
|
||||
Subject: [PATCH 2/2] irrlicht: Fix boolean return type for jpeglib's callback
|
||||
|
||||
Building on certain toolchains can fail due to returning an integer
|
||||
instead of TRUE. In any case, only {TRUE,FALSE} should be used
|
||||
as 'boolean' jpeglib type. Fix this by returning TRUE.
|
||||
|
||||
CImageLoaderJPG.cpp: In static member function 'static boolean
|
||||
irr::video::CImageLoaderJPG::fill_input_buffer(j_decompress_ptr)':
|
||||
CImageLoaderJPG.cpp:69:9: error: invalid conversion from 'int' to 'boolean'
|
||||
[-fpermissive]
|
||||
|
||||
Signed-off-by: Romain Naour <romain.naour@smile.fr>
|
||||
Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
|
||||
---
|
||||
Fix sent upstream as part of pull:
|
||||
https://github.com/supertuxkart/stk-code/pull/2554
|
||||
|
||||
lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp b/lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp
|
||||
index 8fc5222a1e9b..1811f31dd28f 100644
|
||||
--- a/lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp
|
||||
+++ b/lib/irrlicht/source/Irrlicht/CImageLoaderJPG.cpp
|
||||
@@ -66,7 +66,7 @@ void CImageLoaderJPG::init_source (j_decompress_ptr cinfo)
|
||||
boolean CImageLoaderJPG::fill_input_buffer (j_decompress_ptr cinfo)
|
||||
{
|
||||
// DO NOTHING
|
||||
- return 1;
|
||||
+ return TRUE;
|
||||
}
|
||||
|
||||
|
||||
--
|
||||
2.9.0
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Locally computed
|
||||
sha256 0b080bb098a26adb552d6fd48905bcb6b1e873ef1567457d7268d7d3aaa48282 supertuxkart-0.9.2-src.tar.xz
|
||||
# From https://sourceforge.net/projects/supertuxkart/files/SuperTuxKart/0.9.2/
|
||||
sha1 df3805a8f9dc556a0fc5af44442dae8126db5d5a supertuxkart-0.9.2-src.tar.xz
|
||||
md5 f1f5081fd41b8eeb310b4edc07b9ee12 supertuxkart-0.9.2-src.tar.xz
|
||||
sha256 d8014e7106ba84f98b5ec5f146249dcffc284fc4083f8f237ff420b9e2219cb0 supertuxkart-0.9.3-src.tar.xz
|
||||
# From https://sourceforge.net/projects/supertuxkart/files/SuperTuxKart/0.9.3/
|
||||
sha1 2650ba20976472f10122a8600cc239507a9b6f24 supertuxkart-0.9.3-src.tar.xz
|
||||
md5 8de5455b8fdbb92679e302b76c9041cf supertuxkart-0.9.3-src.tar.xz
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
SUPERTUXKART_VERSION = 0.9.2
|
||||
SUPERTUXKART_VERSION = 0.9.3
|
||||
SUPERTUXKART_SOURCE = supertuxkart-$(SUPERTUXKART_VERSION)-src.tar.xz
|
||||
SUPERTUXKART_SITE = http://downloads.sourceforge.net/project/supertuxkart/SuperTuxKart/$(SUPERTUXKART_VERSION)
|
||||
|
||||
@ -29,7 +29,9 @@ SUPERTUXKART_DEPENDENCIES = \
|
||||
|
||||
# Since supertuxkart is not installing libstkirrlicht.so, and since it is
|
||||
# the only user of the bundled libraries, turn off shared libraries entirely.
|
||||
SUPERTUXKART_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF
|
||||
# Disable In-game recorder (there is no libopenglrecorder package)
|
||||
SUPERTUXKART_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF \
|
||||
-DBUILD_RECORDER=OFF
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
|
||||
SUPERTUXKART_DEPENDENCIES += libfribidi
|
||||
|
Loading…
Reference in New Issue
Block a user