package/rygel: bump to version 0.42.5
- Drop first patch (already in version) - Refresh second patch - x11 is mandatory since18cd2cff6f
and upstream doesn't want to make it optional: https://gitlab.gnome.org/GNOME/rygel/-/issues/221 - This bump will also fix the following build failure raised since bump of gupnp to version 1.6.6 in commitb7938d2ae7
: ../output-1/build/rygel-0.40.2/meson.build:79:8: ERROR: Dependency "gupnp-1.2" not found, tried pkgconfig and cmake https://gitlab.gnome.org/GNOME/rygel/-/blob/rygel-0.42.5/NEWS Fixes: - http://autobuild.buildroot.org/results/bdf87468199504384f79e4ab59971776d517296b Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
b3613cc9b3
commit
02734c0c22
@ -1177,8 +1177,7 @@ package/rtorrent/0001-Added--disable-execinfo-option-to-configure.patch Upstream
|
||||
package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch Upstream
|
||||
package/rubix/0001-dont-use-legacy-functions.patch Upstream
|
||||
package/rubix/0002-misc-fixes.patch Sob Upstream
|
||||
package/rygel/0001-build-Add-man_pages-build-options.patch Upstream
|
||||
package/rygel/0002-meson.build-fix-g_ir_compiler-calls.patch Upstream
|
||||
package/rygel/0001-meson.build-fix-g_ir_compiler-calls.patch Upstream
|
||||
package/rygel/S99rygel Indent Shellcheck Variables
|
||||
package/s6-linux-init/0001-configure-add-D_GNU_SOURCE.patch Upstream
|
||||
package/s6-linux-utils/0001-src-s6-linux-utils-rngseed.c-fix-build-with-glibc.patch Upstream
|
||||
|
@ -1,150 +0,0 @@
|
||||
From 5a54c5bb1c9609b7bffe6b3e05f934030e4e990e Mon Sep 17 00:00:00 2001
|
||||
From: Jens Georg <mail@jensge.org>
|
||||
Date: Sat, 26 Dec 2020 18:40:51 +0100
|
||||
Subject: [PATCH] build: Add man_pages build options
|
||||
|
||||
Check if xsltproc runs succesfully and fail otherwise
|
||||
|
||||
Fixes #192
|
||||
|
||||
[Retrieved from:
|
||||
https://gitlab.gnome.org/GNOME/rygel/-/commit/5a54c5bb1c9609b7bffe6b3e05f934030e4e990e]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
doc/man/meson.build | 98 +++++++++++++++++++++++++++------------------
|
||||
doc/meson.build | 5 ++-
|
||||
meson_options.txt | 1 +
|
||||
3 files changed, 64 insertions(+), 40 deletions(-)
|
||||
|
||||
diff --git a/doc/man/meson.build b/doc/man/meson.build
|
||||
index ef3fcfbf5..4c92eab2b 100644
|
||||
--- a/doc/man/meson.build
|
||||
+++ b/doc/man/meson.build
|
||||
@@ -1,43 +1,63 @@
|
||||
xsltproc = find_program('xsltproc', required: false)
|
||||
|
||||
if xsltproc.found()
|
||||
- xlstproc_flags = [
|
||||
- '--nonet',
|
||||
- '--stringparam', 'man.output.quietly', '1',
|
||||
- '--stringparam', 'funcsynopsis.style', 'ansi',
|
||||
- '--stringparam', 'man.authors.section.enabled', '1',
|
||||
- '--stringparam', 'man.copyright.section.enabled', '1',
|
||||
- ]
|
||||
-
|
||||
- xsltproc_args = [
|
||||
- xsltproc,
|
||||
- xlstproc_flags,
|
||||
- '-o', '@OUTPUT@',
|
||||
- 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
|
||||
- '@INPUT@',
|
||||
- ]
|
||||
-
|
||||
- man_input_files = [
|
||||
- 'rygel.xml',
|
||||
- 'rygel.conf.xml'
|
||||
- ]
|
||||
-
|
||||
- man_output_files = [
|
||||
- 'rygel.1',
|
||||
- 'rygel.conf.5'
|
||||
- ]
|
||||
-
|
||||
- custom_target('man 1 pages',
|
||||
- input: 'rygel.xml',
|
||||
- output: 'rygel.1',
|
||||
- command: xsltproc_args,
|
||||
- install: true,
|
||||
- install_dir: join_paths(get_option('mandir'), 'man1'))
|
||||
-
|
||||
- custom_target('man 5 pages',
|
||||
- input: 'rygel.conf.xml',
|
||||
- output: 'rygel.conf.5',
|
||||
- command: xsltproc_args,
|
||||
- install: true,
|
||||
- install_dir: join_paths(get_option('mandir'), 'man5'))
|
||||
+ stylesheet = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
|
||||
+
|
||||
+ xlstproc_flags = [
|
||||
+ '--nonet',
|
||||
+ '--stringparam', 'man.output.quietly', '1',
|
||||
+ '--stringparam', 'funcsynopsis.style', 'ansi',
|
||||
+ '--stringparam', 'man.authors.section.enabled', '1',
|
||||
+ '--stringparam', 'man.copyright.section.enabled', '1',
|
||||
+ ]
|
||||
+
|
||||
+ xsltproc_args = [
|
||||
+ xsltproc,
|
||||
+ xlstproc_flags,
|
||||
+ '-o', '@OUTPUT@',
|
||||
+ stylesheet,
|
||||
+ '@INPUT@',
|
||||
+ ]
|
||||
+
|
||||
+ man_input_files = [
|
||||
+ 'rygel.xml',
|
||||
+ 'rygel.conf.xml'
|
||||
+ ]
|
||||
+
|
||||
+ man_output_files = [
|
||||
+ 'rygel.1',
|
||||
+ 'rygel.conf.5'
|
||||
+ ]
|
||||
+
|
||||
+ r = run_command(
|
||||
+ [
|
||||
+ xsltproc,
|
||||
+ xlstproc_flags,
|
||||
+ '-o', '/dev/null',
|
||||
+ stylesheet,
|
||||
+ 'rygel.xml'
|
||||
+ ]
|
||||
+ )
|
||||
+
|
||||
+ if (r.returncode() == 0)
|
||||
+ custom_target(
|
||||
+ 'man 1 pages',
|
||||
+ input: 'rygel.xml',
|
||||
+ output: 'rygel.1',
|
||||
+ command: xsltproc_args,
|
||||
+ install: true,
|
||||
+ install_dir: join_paths(get_option('mandir'), 'man1')
|
||||
+ )
|
||||
+
|
||||
+ custom_target(
|
||||
+ 'man 5 pages',
|
||||
+ input: 'rygel.conf.xml',
|
||||
+ output: 'rygel.conf.5',
|
||||
+ command: xsltproc_args,
|
||||
+ install: true,
|
||||
+ install_dir: join_paths(get_option('mandir'), 'man5')
|
||||
+ )
|
||||
+ else
|
||||
+ error('Cannot bulid man pages, failed to run xsltproc')
|
||||
+ endif
|
||||
endif
|
||||
diff --git a/doc/meson.build b/doc/meson.build
|
||||
index 41c733e50..91c08fae5 100644
|
||||
--- a/doc/meson.build
|
||||
+++ b/doc/meson.build
|
||||
@@ -1,2 +1,5 @@
|
||||
-subdir('man')
|
||||
+if get_option('man_pages')
|
||||
+ subdir('man')
|
||||
+endif
|
||||
+
|
||||
subdir('reference')
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index cb604c4e9..c60ff1a9a 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -1,5 +1,6 @@
|
||||
option('uninstalled', type: 'boolean', value: 'false', description: 'Run Rygel from build directory only')
|
||||
option('api-docs', type: 'boolean', value: 'false', description: 'Build the API documentation')
|
||||
+option('man_pages', type: 'boolean', value: 'true', description: 'Build the man pages')
|
||||
option('systemd-user-units-dir', type : 'string', value : 'auto', description : 'Where to install the systemd user unit (use special values "auto" or "none", or pass a path')
|
||||
option('plugins', type : 'array', choices : ['external', 'gst-launch', 'lms', 'media-export', 'mpris', 'playbin', 'ruih', 'tracker', 'tracker3'])
|
||||
option('engines', type : 'array', choices : ['simple', 'gstreamer'])
|
||||
--
|
||||
GitLab
|
||||
|
@ -35,12 +35,12 @@ index fd43bebe..e6be2b5e 100644
|
||||
@@ -70,7 +70,9 @@ core_gir = custom_target('RygelCore-2.6.gir',
|
||||
# so we depend on the custom_target from that step and pass the input through
|
||||
# commandline.
|
||||
custom_target('RygelCore-2.6.typelib',
|
||||
- command: [g_ir_compiler, '--output', '@OUTPUT@', join_paths(meson.current_build_dir(), 'RygelCore-2.6.gir')],
|
||||
custom_target('RygelCore-2.8.typelib',
|
||||
- command: [g_ir_compiler, '--output', '@OUTPUT@', join_paths(meson.current_build_dir(), 'RygelCore-2.8.gir')],
|
||||
+ command: [g_ir_compiler, '--output', '@OUTPUT@',
|
||||
+ '--includedir', meson.get_external_property('sys_root') + get_option('prefix') + '/' + gir_dir,
|
||||
+ join_paths(meson.current_build_dir(), 'RygelCore-2.6.gir')],
|
||||
output: 'RygelCore-2.6.typelib',
|
||||
+ join_paths(meson.current_build_dir(), 'RygelCore-2.8.gir')],
|
||||
output: 'RygelCore-2.8.typelib',
|
||||
depends: [ core_lib, core_gir ],
|
||||
install: true,
|
||||
diff --git a/src/librygel-renderer-gst/meson.build b/src/librygel-renderer-gst/meson.build
|
||||
@ -52,8 +52,8 @@ index ad98a3a7..e8baefe1 100644
|
||||
'--includedir', core_girdir,
|
||||
'--includedir', renderer_girdir,
|
||||
+ '--includedir', meson.get_external_property('sys_root') + get_option('prefix') + '/' + gir_dir,
|
||||
join_paths(meson.current_build_dir(), 'RygelRendererGst-2.6.gir')],
|
||||
output: 'RygelRendererGst-2.6.typelib',
|
||||
join_paths(meson.current_build_dir(), 'RygelRendererGst-2.8.gir')],
|
||||
output: 'RygelRendererGst-2.8.typelib',
|
||||
depends: [renderer_gst_lib, renderer_lib, renderer_gst_gir, renderer_gir],
|
||||
diff --git a/src/librygel-renderer/meson.build b/src/librygel-renderer/meson.build
|
||||
index 5f401527..821273ff 100644
|
||||
@ -64,7 +64,7 @@ index 5f401527..821273ff 100644
|
||||
'--output', '@OUTPUT@',
|
||||
'--includedir', core_girdir,
|
||||
+ '--includedir', meson.get_external_property('sys_root') + get_option('prefix') + '/' + gir_dir,
|
||||
join_paths(meson.current_build_dir(), 'RygelRenderer-2.6.gir')],
|
||||
join_paths(meson.current_build_dir(), 'RygelRenderer-2.8.gir')],
|
||||
output: 'RygelRenderer-2.6.typelib',
|
||||
depends: [ renderer_lib, renderer_gir, core_gir ],
|
||||
diff --git a/src/librygel-server/meson.build b/src/librygel-server/meson.build
|
||||
@ -76,7 +76,7 @@ index a3bd77d9..6b084eb6 100644
|
||||
'--output', '@OUTPUT@',
|
||||
'--includedir', core_girdir,
|
||||
+ '--includedir', meson.get_external_property('sys_root') + get_option('prefix') + '/' + gir_dir,
|
||||
join_paths(meson.current_build_dir(), 'RygelServer-2.6.gir')],
|
||||
join_paths(meson.current_build_dir(), 'RygelServer-2.8.gir')],
|
||||
output: 'RygelServer-2.6.typelib',
|
||||
depends: [ server_lib, server_gir, core_gir ],
|
||||
--
|
@ -1,5 +1,6 @@
|
||||
config BR2_PACKAGE_RYGEL
|
||||
bool "rygel"
|
||||
depends on BR2_PACKAGE_XORG7
|
||||
depends on BR2_USE_WCHAR # gupnp-av
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS # gupnp-av
|
||||
depends on BR2_USE_MMU # gupnp-av, gobject-introspection
|
||||
@ -15,6 +16,7 @@ config BR2_PACKAGE_RYGEL
|
||||
select BR2_PACKAGE_LIBGEE
|
||||
select BR2_PACKAGE_LIBMEDIAART
|
||||
select BR2_PACKAGE_SQLITE
|
||||
select BR2_PACKAGE_XLIB_LIBX11
|
||||
help
|
||||
Rygel is a home media solution (UPnP AV MediaServer) that
|
||||
allows you to easily share audio, video and pictures to other
|
||||
@ -57,6 +59,7 @@ endif # BR2_PACKAGE_RYGEL
|
||||
comment "rygel needs python3 and a glibc toolchain w/ wchar, threads, gcc >= 4.9, host gcc >= 8"
|
||||
depends on BR2_USE_MMU
|
||||
depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
|
||||
depends on BR2_PACKAGE_XORG7
|
||||
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
|
||||
!BR2_TOOLCHAIN_USES_GLIBC || \
|
||||
!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
|
||||
|
@ -1,5 +1,5 @@
|
||||
# Hash from: https://download.gnome.org/sources/rygel/0.40/rygel-0.40.2.sha256sum:
|
||||
sha256 c9e8c736296d22c4defe959727a29d31437bbd2b7aa0c6470d6be24011050697 rygel-0.40.2.tar.xz
|
||||
# Hash from: https://ftp.gnome.org/pub/gnome/sources/rygel/0.42/rygel-0.42.5.sha256sum:
|
||||
sha256 1133602d2e6710aade6b22aa98d93384c8d56396f344763413e96e0110b7d89f rygel-0.42.5.tar.xz
|
||||
|
||||
# Locally calculated
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
RYGEL_VERSION_MAJOR = 0.40
|
||||
RYGEL_VERSION = $(RYGEL_VERSION_MAJOR).2
|
||||
RYGEL_VERSION_MAJOR = 0.42
|
||||
RYGEL_VERSION = $(RYGEL_VERSION_MAJOR).5
|
||||
RYGEL_SOURCE = rygel-$(RYGEL_VERSION).tar.xz
|
||||
RYGEL_SITE = https://download.gnome.org/sources/rygel/$(RYGEL_VERSION_MAJOR)
|
||||
RYGEL_LICENSE = LGPL-2.1+, CC-BY-SA-3.0 (logo)
|
||||
@ -18,6 +18,7 @@ RYGEL_DEPENDENCIES = \
|
||||
libgee \
|
||||
libmediaart \
|
||||
sqlite \
|
||||
xlib_libX11 \
|
||||
$(TARGET_NLS_DEPENDENCIES)
|
||||
RYGEL_INSTALL_STAGING = YES
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user