package/libubootenv: bump to version 0.3.2

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Francois Perrad 2021-05-17 12:39:59 +02:00 committed by Yann E. MORIN
parent 0071501828
commit 0173c06e5d
3 changed files with 9 additions and 8 deletions

View File

@ -26,10 +26,10 @@ Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a04dd11..3a2115d 100644
index 4b71bc5..0b515f4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,17 +12,15 @@ SET(include_HEADERS
@@ -12,18 +12,16 @@ SET(include_HEADERS
include(GNUInstallDirs) # for the CMAKE_INSTALL_LIBDIR variable
@ -41,8 +41,9 @@ index a04dd11..3a2115d 100644
-SET_TARGET_PROPERTIES(ubootenv_static PROPERTIES OUTPUT_NAME ubootenv)
add_executable(fw_printenv fw_printenv.c)
add_executable(fw_setenv fw_setenv.c)
target_link_libraries(fw_printenv ubootenv z)
target_link_libraries(fw_setenv ubootenv z)
target_link_libraries(ubootenv z)
target_link_libraries(fw_printenv ubootenv)
target_link_libraries(fw_setenv ubootenv)
-install (TARGETS ubootenv ubootenv_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install (TARGETS ubootenv DESTINATION ${CMAKE_INSTALL_LIBDIR})
@ -50,5 +51,5 @@ index a04dd11..3a2115d 100644
install (TARGETS fw_printenv DESTINATION ${CMAKE_INSTALL_BINDIR})
install (TARGETS fw_setenv DESTINATION ${CMAKE_INSTALL_BINDIR})
--
2.25.1
2.30.2

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 e25adf81dd2d4a083cb2cf032843a1ee2bb1fab54aa7a0202bd2295186bfe1b7 libubootenv-e663439e3d39a4cdbddb7e818245a99c485fa965.tar.gz
sha256 662ef1efe058e2d5a07498f7b63aff7b2a521c0f6f199c499fb3ae84b54121bd libubootenv-0.3.2.tar.gz
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 Licenses/lgpl-2.1.txt

View File

@ -4,8 +4,8 @@
#
################################################################################
LIBUBOOTENV_VERSION = e663439e3d39a4cdbddb7e818245a99c485fa965
LIBUBOOTENV_SITE = $(call github,sbabic,libubootenv,$(LIBUBOOTENV_VERSION))
LIBUBOOTENV_VERSION = 0.3.2
LIBUBOOTENV_SITE = $(call github,sbabic,libubootenv,v$(LIBUBOOTENV_VERSION))
LIBUBOOTENV_LICENSE = LGPL-2.1
LIBUBOOTENV_LICENSE_FILES = Licenses/lgpl-2.1.txt
LIBUBOOTENV_INSTALL_STAGING = YES