package/bluez5_utils: fix sixaxis build without tools

Fix the following build failure raised since bump to version 5.75 in
commit b890206876 and
https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=9f71892b63f6b65dab874a633d88ae2dcad93a16:

/home/autobuild/autobuild/instance-2/output-1/host/lib/gcc/x86_64-buildroot-linux-musl/12.3.0/../../../../x86_64-buildroot-linux-musl/bin/ld: plugins/bluetoothd-sixaxis.o: in function `sixaxis_init':
sixaxis.c:(.text.sixaxis_init+0x23): undefined reference to `udev_new'

Fixes: b890206876
 - http://autobuild.buildroot.org/results/c337d0f473c5fbb3e6cda1317ba06f5e2b16a43e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2024-05-09 09:49:32 +02:00 committed by Thomas Petazzoni
parent 2a23bd9eff
commit 00773beaaf
2 changed files with 36 additions and 0 deletions

View File

@ -0,0 +1,35 @@
From f4795bf64dbf8778fc765b7dad1b1bfb365b48d7 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Wed, 8 May 2024 19:54:16 +0200
Subject: configure.ac: fix sixaxis build without tools
Fix the following build failure with --enable-sixaxis --enable-udev
--disable-tools raised since version 5.73 and
9f71892b63f6b65dab874a633d88ae2dcad93a16:
sixaxis.c:(.text.sixaxis_init+0x23): undefined reference to `udev_new'
Fixes: http://autobuild.buildroot.org/results/c337d0f473c5fbb3e6cda1317ba06f5e2b16a43e
Upstream: https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=f4795bf64dbf8778fc765b7dad1b1bfb365b48d7
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 9dea70ddc1..8b3cdb4e8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,7 +226,7 @@ AM_CONDITIONAL(MONITOR, test "${enable_monitor}" != "no")
AC_ARG_ENABLE(udev, AS_HELP_STRING([--disable-udev],
[disable udev device support]), [enable_udev=${enableval}])
-if (test "${enable_tools}" != "no" && test "${enable_udev}" != "no"); then
+if (test "${enable_udev}" != "no"); then
PKG_CHECK_MODULES(UDEV, libudev >= 196)
AC_DEFINE(HAVE_UDEV, 1, [Define to 1 if udev is required])
fi
--
cgit 1.2.3-korg

View File

@ -9,6 +9,7 @@ BLUEZ5_UTILS_VERSION = 5.75
BLUEZ5_UTILS_SOURCE = bluez-$(BLUEZ5_UTILS_VERSION).tar.xz
BLUEZ5_UTILS_SITE = $(BR2_KERNEL_MIRROR)/linux/bluetooth
# 0001-configure.ac-Fix-disable-cups.patch
# 0002-configure.ac-fix-sixaxis-build-without-tools.patch
BLUEZ5_UTILS_AUTORECONF = YES
BLUEZ5_UTILS_INSTALL_STAGING = YES
BLUEZ5_UTILS_LICENSE = GPL-2.0+, LGPL-2.1+