lua: bump to version 5.3.2

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Francois Perrad 2015-12-01 20:20:14 +01:00 committed by Thomas Petazzoni
parent 7152c5c5ce
commit 00125048cb
6 changed files with 6 additions and 8 deletions

View File

@ -14,7 +14,7 @@ Index: b/etc/lua.pc
+# grep '^V=' ../Makefile
+V= 5.3
+# grep '^R=' ../Makefile
+R= 5.3.0
+R= 5.3.2
+
+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+prefix= /usr

View File

@ -8,7 +8,7 @@ Index: b/src/lua.c
===================================================================
--- a/src/lua.c
+++ b/src/lua.c
@@ -83,6 +83,15 @@
@@ -83,6 +83,13 @@
#define lua_saveline(L,line) ((void)L, add_history(line))
#define lua_freeline(L,b) ((void)L, free(b))
@ -16,9 +16,7 @@ Index: b/src/lua.c
+
+#include <linenoise.h>
+#define lua_readline(L,b,p) ((void)L, ((b)=linenoise(p)) != NULL)
+#define lua_saveline(L,idx) \
+ if (lua_rawlen(L,idx) > 0) /* non-empty line? */ \
+ linenoiseHistoryAdd(lua_tostring(L, idx)); /* add it to history */
+#define lua_saveline(L,line) ((void)L, linenoiseHistoryAdd(line))
+#define lua_freeline(L,b) ((void)L, free(b))
+
#else /* }{ */

View File

@ -1,6 +1,6 @@
# Hashes from: http://www.lua.org/ftp/
md5 797adacada8d85761c079390ff1d9961 lua-5.3.1.tar.gz
sha1 1676c6a041d90b6982db8cef1e5fb26000ab6dee lua-5.3.1.tar.gz
md5 33278c2ab5ee3c1a875be8d55c1ca2a1 lua-5.3.2.tar.gz
sha1 7a47adef554fdca7d0c5536148de34579134a973 lua-5.3.2.tar.gz
md5 913fdb32207046b273fdb17aad70be13 lua-5.2.4.tar.gz
sha1 ef15259421197e3d85b7d6e4871b8c26fd82c1cf lua-5.2.4.tar.gz

View File

@ -5,7 +5,7 @@
################################################################################
ifeq ($(BR2_PACKAGE_LUA_5_3),y)
LUA_VERSION = 5.3.1
LUA_VERSION = 5.3.2
else
ifeq ($(BR2_PACKAGE_LUA_5_2),y)
LUA_VERSION = 5.2.4